[リストへもどる]
一 括 講 読

投稿時間:17/11/13(Mon) 15:01
投稿者名:りょうぞう
Eメール:ryozo@r-ken.co.jp
URL :
タイトル:PHPバージョンアップについて
PHP7.1へのバージョンアップですがざっと調べた限りでは
半分くらいのサイトで動かないようです
例としてwordpressだとテンプレートやプラグインが古い等があります
もうちょっと調査してまた状況を報告します

投稿時間:17/11/16(Thu) 16:05
投稿者名:りょうぞう
Eメール:ryozo@r-ken.co.jp
URL :
タイトル:PHPバージョンアップについて2
php7に上げた場合の不具合点をまとめました
今のところ解決案は2案です。
もうちょっと試行錯誤して別の案がないか検討します


1.)php7にバージョン上げるにあたり昔のバージョンのwordpress等は動作しません
※php7非互換命令を使っているため
2.)php7.1+最新のwordpress の場合、mysqlに接続できません
※mysqlのバージョンを上げる必要あり
ただしmysqlのバージョンを上げた場合、旧バージョンと非互換になり現在動いているwordpressからmysqlに接続できない

----------
案1
最新wordpressの動作要項はあくまで奨励環境であり現在のphp5.2でも動作に問題はないのでとりあえずそのまま

案2
php7専用にmysqlサーバーを新規で立てる
利用者はphp7用のmysqlサーバーと使う



- Web Forum -